Elevated Engagement Errors

Incident Report for Gainsight PX

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 09:31 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 09:28 PDT

Investigating

We are currently investigating reports of errors when saving new or draft engagements. Some users may see a failed save notification even when the action completes successfully. We are actively working to identify the root cause and will provide an update shortly.
Posted Sep 04, 2026 - 09:00 PDT
This incident affected: UI and Email Engagement.