PX Engagements and Knowledge Center (KC) Bots
Incident Report for Gainsight PX
Postmortem

Summary of Incident:

Some customers were unable to use Engagements and KC Bots between 9:02 and 10:38 PDT on July 17, then again between 7:18 and 14:38 PDT on July 18, 2023.

Root Cause:

A high availability caching cluster re-election had an issue while handling real time traffic due to a bug, which caused an increase in latency.

Action Items:

Our Engineering Team identified and resolved the issue caused from the initial bug.

Please reach out to pxsupport@gainsight.com if you have questions.

Posted Jul 26, 2023 - 14:52 PDT

Resolved
This is resolved and affected customers should be seeing improvements now. RCA details will be posted as they become available.
Please email pxsupport@gainsight.com with any questions.
Posted Jul 18, 2023 - 14:38 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2023 - 12:30 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 18, 2023 - 07:19 PDT
Identified
We are working to resolve an identified issue causing slowness in PX engagement and Knowledge Center (KC) Bots.
Please email pxsupport@gainsight.com with any questions.
Posted Jul 18, 2023 - 07:18 PDT
This incident affected: In-app Guides and In-app Surveys.