Investigating Connectivity Issues: PX to Salesforce Integration

Incident Report for Gainsight PX

Identified

We are working to ensure all relevant IPs are properly updated. A permanent fix is scheduled to be applied by February 27, 2026.
Posted Feb 23, 2026 - 07:44 PST

Investigating

We have identified an issue causing intermittent connection failures between PX and Salesforce for some users.

Technical Detail:
Our team has found that a specific IP address used by PX is missing from some Salesforce IP allow lists. This discrepancy may result in failed syncs or authentication errors as Salesforce environment strictly enforces IP restrictions.

Please email pxsupport@gainsight.com with any questions.
Posted Feb 23, 2026 - 07:43 PST
This incident affects: Connectors.