PX Engagements and Knowledge Center (KC) Bots
Incident Report for Gainsight PX
Postmortem

Summary of Incident: Customers using PX, either as a customer or consumer, were unable to use Engagements and KC Bots starting on April 25, 2023 6:30 am PDT that was resolved by 15:38 PDT. 

Root Cause: The April 25  incident was caused by two issues:

  1. A caching cluster slow-down. This cluster is what serves the KC Bot and Engagements portion of the product
  2. Intermittent KC Bot synchronization issues due to malformed data

Immediate Action Items:

  1. Caching Cluster sizing and configuration adjustments
  2. KC Bot Configuration adjustments and a protection mechanism for malformed data issues

Please reach out to pxsupport@gainsight.com if you have questions.

Posted May 02, 2023 - 15:52 PDT

Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 15:38 PDT
Update
Our Engineering team is rolling out a fix and the ETA for full resolution is 3 hours.
Posted Apr 25, 2023 - 12:02 PDT
Identified
Some customers may have issues with PX Engagements or Knowledge Center (KC) Bots. We have identified the cause and we're rolling out a fix.
Start time of this issue: 1:00 PM UTC
Posted Apr 25, 2023 - 08:28 PDT